Back to overview
Degraded

User Registration API Issues

Nov 04 at 09:33am CET
Affected services
API

Resolved
Nov 11 at 12:45pm CET

Updated Nov 11 at 12:45pm CET

  • Status: Monitoring - Fix Deployed
  • Affected Service: User Registration
  • First Detected: October 28, 2025
  • Last Updated: November 11, 2025

Summary

We have successfully deployed a fix for the registration issues. You can now create new accounts again! We're keeping a close eye on things to make sure everything continues running smoothly.

What We Fixed

The registration system wasn't properly checking that your password and password confirmation matched. This has now been corrected, and the registration process is working as intended.

Current Status

The fix is live and working. Our initial tests show:
- ✓ You can successfully register with a new account
- ✓ The system now properly checks that your passwords match
- ✓ Registration is responding normally

What's Next

We'll continue monitoring the registration system over the next day or two to ensure everything remains stable. Once we're confident everything is running smoothly, we'll mark this incident as fully resolved.

We sincerely apologize for the inconvenience this caused and appreciate your patience while we worked to resolve this issue.

Updated
Nov 04 at 12:24pm CET

  • Status: Identified - Fix in Progress
  • Affected Service: User Registration API (/api/register)
  • First Detected: October 28, 2025
  • Last Updated: November 4, 2025

Summary

We have identified the root cause of the 403 Forbidden errors affecting our /api/register endpoint and are currently implementing a fix. Users are unable to complete new account registrations at this time.

What We Know

The /api/register endpoint has been returning 403 Forbidden errors since October 28, 2025
Root cause identified: Missing password confirmation validation in our registration endpoint
The endpoint is not properly handling form-encoded registration requests

Current Status

Our engineering team has identified the specific code changes required to resolve this issue. We are currently:
- Implementing password confirmation validation
- Updating request parameter handling to support form-encoded data
- Preparing the fix for deployment

Next Steps

  • Complete code implementation and internal testing
  • Deploy fix to production environment
  • Verify registration functionality is fully restored
  • Conduct post-incident review

We apologize for the inconvenience and will provide another update once the fix has been deployed.

Created
Nov 04 at 09:33am CET

  • Status: Investigating
  • Affected Service: User Registration API (/api/register)
  • First Detected: October 28, 2025
  • Last Updated: November 4, 2025

Summary

We are currently investigating issues with our /api/register endpoint that is returning 403 Forbidden errors. Our team has identified the scope of the issue and is actively working on a resolution.

What We Know

The /api/register endpoint is experiencing 403 Forbidden errors
Multiple registration attempts have been affected since October 28, 2025

Current Status

Our engineering team is actively investigating the root cause of the 403 errors on the registration endpoint. We are working to identify whether this is related to authentication, permissions, or configuration issues.

What We're Doing

  • Analyzing server logs and error patterns
  • Reviewing recent changes to the registration service
  • Testing potential fixes in our staging environment

We will provide updates as we learn more. Thank you for your patience.